Reply
Logi Browser
Chipteck
Posts: 5
Registered: ‎07-17-2013

Impossible to use my Logitech HD Pro C920 on Windows 8 x64 (Asus Z87-Deluxe)

[ Edited ]

It appears that I am also in the situation where I have no video stream, I have the following setup:

 

Asus Z87-Deluxe with Win8/64 and I had the camera fully functional until I installed AiSuite and video stream promptly broke.

The upgrade for AiCharger fixed the problem and the subsequent AiSuite upgrade left the video stream operational, but subsequently it broke.

In my troubleshooting, I have uninstalled AiSuite and also ran Asus AiSuite_cleaner to remove all traces and then I uninstalled the LWS280 in order to start fresh.

When I install LWS280, it appears to recognise the C920 and completes the installation normally, but no video stream.

Not sure how to trace the video stream in order to determine where it breaks.

 

Under Imaging devices I also have an HP scanjet that is operational and the USB microscope which is operational when plugged in. Unfortunately I am not entirely sure when the C920 stopped working but the only thing that I recall is that when

AiSuite was installed last, Skype still located and used the C920..

 

Chipteck

 

[edited title to reflect content]

Support Specialist ★★★★
jc1990
Posts: 4,402
Registered: ‎08-02-2012

Re: Impossible to use my Logitech HD Pro C920 on Windows 8 x64 (Asus Z87-Deluxe)

Hi Chipteck,

 

I would recommend to contact Asus for any incompatibility issues with our software or webcam drivers since you estate that this happened after an update. I would also recommend to connect your C920 to another computer to see if it works or if you experience the same behavior. This will help us isolate the issue and know if this is a problem with your C920 or the update of your AiSuite.

Kind regards,

Camacho
Support Specialist

If a reply adequately addresses your technical issue, please click on the "Accept as Solution" and "Give Kudos" button so this information can benefit other users via search.

Logitech

Support Home Page | Downloads | Contact Support | Manuals | Warranty | Check Rebate Status
All opinions written here are my own and do not necessarily reflect the views and opinions of my employer.


Logi Browser
Chipteck
Posts: 5
Registered: ‎07-17-2013

Re: Impossible to use my Logitech HD Pro C920 on Windows 8 x64 (Asus Z87-Deluxe)

I am in the process of also following up with ASUS.

I should have mentioned that the C920 runs file on Asus P8Z77-V Deluxe with Win 8/64 amd my JP Laptop with Win 7/64 and also on my Mac systems, the issue seems to be localized to the Z87 series and their USB implementation.

 

Thank you for your time,

 

Chipteck

Logi Nu
MAnderberg
Posts: 2
Registered: ‎10-10-2013

Re: Impossible to use my Logitech HD Pro C920 on Windows 8 x64 (Asus Z87-Deluxe)

Hi,

 

I have the exact same issue, with the same motherboard and I too have verified that the camera works fine on other systems. I hope that either you Chipteck or ASUS come up with an idea what might be causing it?

 

/Mike

Logi Nu
MAnderberg
Posts: 2
Registered: ‎10-10-2013

Re: Impossible to use my Logitech HD Pro C920 on Windows 8 x64 (Asus Z87-Deluxe)

Hi again everyone,

 

I've now tried the AiCharger+ Hotfix available on the ASUS-site and that resolved it. So now it works. Thanks for the tip Chipteck!

 

/Mike